Задать вопрос
21 декабря, 15:42

Напистаь программу удаления из строки чётных или нечётных чисел в Паскале

+1
Ответы (1)
  1. 21 декабря, 16:28
    0
    Что значит из строки? Формулируйте лучше. Можно делать через обычный массив, примерно так

    var

    a : array [1 ... 100] of integer; / / Вместо 100 - максимальное количество чисел

    i, n : integer;

    begin

    //Если колчисетво чисел вводится, то этот код

    read (n) ;

    for i : = 1 to n do

    read (a[i]) ;

    //Если же по уловию задачи задана только строка чисел, то использовать следующий

    //код

    while not eoln (input) do

    begin

    n : = n + 1;

    read (a[n]) ;

    end;

    //Далее для обоих вариантов.

    for i : = 1 to n do

    if a[i] mod 2 = 0 then write (a[i], ' ') ; / / Выведет четные, для нечетных заменить = 0 на = 1

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напистаь программу удаления из строки чётных или нечётных чисел в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных.
Ответы (1)
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Написать программу которая минимальное значение четных и не четных в заданном диапазоне и сумму и среднее ариф. Всех и четных и нечетных. python3 через цикл while
Ответы (1)