Задать вопрос
29 апреля, 04:18

Дано натуральное число N и действительное число x. Вычислить сумму ряда:

sin x + sin 2x+sin 3x+ ... sin N*X

Протестировать программу для x=1.5 и N=3. Проверить правильность ответа на калькуляторе.

+3
Ответы (1)
  1. 29 апреля, 06:28
    0
    var

    n, i: integer;

    x, s: real;

    begin

    repeat

    writeln ('Введите количество слагаемых:') ;

    readln (n)

    until n>0;

    writeln ('Введите ''x'':') ;

    readln (x) ;

    for i : = 1 to n do

    s : = s + sin (i * x) ;

    writeln (s) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число N и действительное число x. Вычислить сумму ряда: sin x + sin 2x+sin 3x+ ... sin N*X Протестировать программу для ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Составить на паскале программу для вычисления суммы ряда:s=1+1/2+1/3+1/4 + ... 1/n число n вводится с клавиатуры. протестировать программу для n=1, n=2, n=4, n=6. правильность ответов проверить с помощью калькулятора.
Ответы (1)
Разработать схему алгоритма для вычисления суммы ряда:S=1/2+1/3+1/4 ... 1/N. Число N вводится с клавиатуры. Протестировать алгоритм для N=1, N=2, N=4, N=6. Правильность ответов проверить с помощью калькулятора.
Ответы (1)
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
Дано натуральное число Х. Вычислить Y = 1 - 2X + 3X2 (в квадрате) - 4X3 (в третьей степени). Разрешается использовать не более 8 арифметических операций. Допустимы: операции сложение, вычитание, умножение. Протестировать программу для X=0, X=1, X=-2.
Ответы (1)