Задать вопрос
2 ноября, 09:22

Дано натуральное число Х. Вычислить Y = 1 - 2X + 3X2 (в квадрате) - 4X3 (в третьей степени). Разрешается использовать не более 8 арифметических операций. Допустимы: операции сложение, вычитание, умножение. Протестировать программу для X=0, X=1, X=-2.

+5
Ответы (1)
  1. 2 ноября, 11:44
    0
    Var

    step: array[1 ... 8] of real;

    i, x: integer;

    begin

    readln (x) ;

    step[1] : = 1 - x;

    step[2] : = step[1] * step[1];

    step[3] : = step[2] * step[1];

    step[4] : = 3 * x;

    step[5] : = step[4] * x;

    step[6] : = 1 - step[5];

    step[7] : = step[6] * x;

    step[8] : = step[3] + step[7];

    for i : = 1 to 8 do

    write (step[i], ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число Х. Вычислить Y = 1 - 2X + 3X2 (в квадрате) - 4X3 (в третьей степени). Разрешается использовать не более 8 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию.
Ответы (1)
Используя числа 1, 3, 4, 6, арифметические операции (сложение, вычитание, умножение, деление) и скобки, получить число 24. Разрешается использовать только эти числа и только эти операции. Каждое число должно использоваться один и только один раз.
Ответы (1)
Используя однозначные числа 1,3,4,6 арифметические операции (сложение, вычитание, умножение, деление) и скобки, получите 24. Разрешается использовать только эти числа, и только эти операции. Каждое число должно использоваться один и только один раз.
Ответы (1)
Дано натуральное число Х. Вычислить Y=X5. Разрешается использовать только три операции умножения. Разработать алгоритм для решения этой задачи. Протестировать алгоритм для Х=2 и Х=3
Ответы (1)
С + + Реализовать в виде класса набор подпрограмм для выполнения следующих операций над обыкновенными дробями вида (P - целое, Q - натуральное) : 1) сложение; 2) вычитание; 3) умножение; 4) деление; 5) сокращение дроби;
Ответы (1)