Задать вопрос
23 сентября, 06:37

Паскаль. Составьте программу вычисления в массиве A (N) произведения четных элементов. Массив сформировать с помощью генератора случайных чисел.

+1
Ответы (1)
  1. 23 сентября, 07:21
    0
    const

    n=15;

    var

    a:array [1 ... n] of integer;

    i:integer;

    p:longint;

    begin

    randomize;

    p:=1;

    for i:=1 to n do begin

    a[i]:=random (9) + 1;

    write (a[i]:2) ;

    if a[i] mod 2 = 0 then p:=p*a[i];

    end;

    writeln;

    writeln ('Proizvedenie: ', p) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Составьте программу вычисления в массиве A (N) произведения четных элементов. Массив сформировать с помощью генератора случайных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Создать программу. Сформировать массив В (15). состоящий из чисел до 50. Найти сумму элементов этого массива. Массив сформировать при помощи генератора случайных чисел, элементы вывести на экран.
Ответы (1)
Сформировать массив А из 30 случайных целых чисел в диапазоне от-30 да 50. Сформировать массивы С, В которые содержат: массив В - четные элементы из массива А в порядке их следования в массиве А, массив С - отрицательные элементы массива А в
Ответы (1)
Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35; 35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов;
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)