Задать вопрос
12 февраля, 06:55

Дана матрица раз мерности NxM. В каждой строке матрицы посчитать количество отрицательных элементов.

+5
Ответы (1)
  1. 12 февраля, 09:34
    0
    uses crt;

    var

    a:array [1 ... 100,1 ... 100] of real;

    n, m, k:integer;

    begin

    clrscr;

    randomize;

    write ('N=') ; read (n) ;

    write ('M=') ; read (m) ;

    for n:=1 to n do

    for m:=1 to m do

    a[n, m]:=random (100) - 50;

    for n:=1 to n do

    begin

    for m:=1 to m do

    write (a[n, m],' ') ;

    writeln;

    end;

    for n: = 1 to n do

    begin

    k:=0;

    for m: = 1 to m do

    begin

    if a[n, m]<0 then

    k:=k+1;

    end;

    writeln ('К ол-во отрицательных элементов ', n, ' строки: ', k) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана матрица раз мерности NxM. В каждой строке матрицы посчитать количество отрицательных элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Задана матрица размером NxM. Определить k - количество "особых" элементов матрицы, считая элемент "особым", если он больше суммы остальных элементов своего столбца.
Ответы (1)
6 вариант. Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С = В - А. Дана вещественная матрица А (N. M). Составить программу замены всех отрицательных элементов матрицы на элемент, имеющий максимальное значение.
Ответы (1)
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)