Задать вопрос
26 мая, 09:14

Дано слово s1, получить слово s2, образованное буквами слова s1, стоящее на четных местах

+4
Ответы (1)
  1. 26 мая, 11:58
    0
    var

    s1, s2: string;

    i: integer;

    begin

    s2: = ''; / / Присваиваем строке начальное пустое значение

    writeln ('Введите слово s1') ;

    readln (s1) ;

    for i: = 1 to length (s1) do / / length (s1) - длина строки s1

    if i mod 2 = 0 then s2: = s2 + s1[i];

    writeln ('Полученное слово: ', s2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано слово s1, получить слово s2, образованное буквами слова s1, стоящее на четных местах ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу:"Дано четырехзначное число. Что больше: сумма цифр, стоящих на четных местах, или сумма цифр, стоящих на не четных местах?"
Ответы (1)
Заполнить массив случайными числами в интервале[ - 100; 100] и поменять местами соединение элементы, стоящие на четных местах, с элементами, стоящими на нечетных местах. Вычислить кол-во четных элементов. Гномья сортировка.
Ответы (1)
В одномерном массиве, состоящем из n элементов, вычислить: 1) количество отрицательных элементов массива, расположенных на четных местах 2) сумму четных элементов массива, расположенных на нечетных местах.
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)