Задать вопрос
3 февраля, 16:54

Дан массив из 10 элементов. Подсчитать сумму трехзначных элементов массива, оканчивающихся нулем.

+5
Ответы (2)
  1. 3 февраля, 18:32
    0
    1 2 3 4 5 6 7 8 9 10 11 12 13 var a : array [ 1 ... 10 ] of integer; i : integer; k : integer; begin writeln ('Введите массив: ') ; for i : = 1 to 10 do readln (a [ i ]) ; for i : = 1 to 10 do if (a [ i ] mod 10 = 0) then inc (k) ; writeln ('Исходный массив: ') ; for i : = 1 to 10 do write (a [ i ], ' ') ; writeln; writeln ('Количество чисел оканичвающихся нулем равно: ', k) ; end.
  2. 3 февраля, 19:29
    0
    var

    a:array [1 ... 10] of integer;

    s, i:integer;

    begin

    for i:=1 to 10 do begin

    write ('A[', i,'] = ') ; readln (a[i]) ;

    if (a[i] mod 10 = 0) and (a[i] div 100 in [1 ... 9]) then s:=s+a[i];

    end;

    writeln ('Summa: ', s) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 10 элементов. Подсчитать сумму трехзначных элементов массива, оканчивающихся нулем. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)