Задать вопрос
1 июня, 13:26

Дана последовательность из М чисел. Подсчитать, сколько в ней отрицательных, положительных и нулевых элементов

+5
Ответы (1)
  1. 1 июня, 14:10
    0
    var a:array [1 ... M] of integer;

    i, p, k, n, M:integer;

    begin

    p:=0;

    k:=0;

    n:=0;

    readln (M) ;

    for i:=1 to M do

    readln (a[i]) ;

    for i:=1 to M do

    if a[i]>0 then p:=p+1 else

    if a[i]<0 then k:=k+1 else n:=n+1;

    writeln (p, k, n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность из М чисел. Подсчитать, сколько в ней отрицательных, положительных и нулевых элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
25. Дан одномерный массив. Подсчитать количество положительных и отрицательных элементов. Нулевых элементов в массиве нет.
Ответы (1)
Дан целочисленный одномерный массив, состоящий и n элементов. Подсчитать количество его положительных, отрицательных и нулевых элементов.
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)
Дан массив действительных чисел, размерность которого N. Подсчитать, сколько в нём отрицательных, положительных и нулевых элементов.
Ответы (1)
Помогите написать задачу (любую на выбор) в С#. 1. Дан массив чисел, размерность которого N. Подсчитать, сколько в нем отрицательных, положительных и нулевых элементов. 2. Даны целые числа a1, a2, ..., an.
Ответы (1)