Задать вопрос
1 февраля, 13:01

Дан целочисленный одномерный массив, состоящий и n элементов. Подсчитать количество его положительных, отрицательных и нулевых элементов.

+2
Ответы (1)
  1. 1 февраля, 13:52
    0
    Var a: array[1 ... 10000] of integer;

    x, y, z, i, n:integer;

    begin

    Write ('Введите количество элементов массива: ') ;

    readln (n) ;

    Writeln ('Введите элементы массива: ') ;

    x:=0; z:=0; y:=0;

    for i : = 1 to n do

    begin

    readln (a[i]) ;

    if (a[i]) >0 then

    x:=x+1 else

    if (a[i]) = 0 then

    z:=z+1 else

    y:=y+1;

    end;

    Writeln ('Положительных элкментов масива: ', x) ;

    Writeln ('Отрицательных элкментов масива: ', y) ;

    Writeln ('Нулевых элкментов масива: ', z) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный одномерный массив, состоящий и n элементов. Подсчитать количество его положительных, отрицательных и нулевых элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
25. Дан одномерный массив. Подсчитать количество положительных и отрицательных элементов. Нулевых элементов в массиве нет.
Ответы (1)
1. Дан одномерный целочисленный массив. Найти числа, которые при делении на 3 и 5 дают одинаковые остатки, посчитать их количество. Если такий чисел нет, то вывести соответствующее сообщение. 1. Д ан одномерный целочисленный массив.
Ответы (1)