Задать вопрос
31 августа, 04:01

Составить программу в которой записать в массив N номера положительных элементов массива (x1, x2 ... x15)

+3
Ответы (1)
  1. 31 августа, 05:14
    0
    var

    N: array [1 ... 15] of 1 ... 15; {Массив, в который записываются номера положительных элементов массива х}

    x: array [1 ... 15] of real; / / Массив х

    i: integer; / / Переменная для цикла

    Number: integer; / / Сколько номеров было записано

    begin

    Number: = 0; / / Обнуляем счетчик номеров

    for i: = 1 to 15 do / / Вводим с клавиатуры массив х

    begin

    writeln ('Введите ', i, ' элемент массива х') ;

    readln (x[i]) ;

    if x[i] > 0 then {Если введенный элемент массива х положительный, то прибавляем к счетчику добавленных номеров 1 и присваиваем соответствующему элементу массива N номер элемента}

    begin

    Number: = Number + 1;

    N[Number]: = i;

    end;

    end;

    write ('Номера положительных элементов массива х: ') ;

    for i: = 1 to Number do write (n[i], ' ') ; / / Выводим записанные номера элементов

    writeln; {Переход на новую строку, чтобы при следующем запуске программы информация выводилась с новой строки}

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в которой записать в массив N номера положительных элементов массива (x1, x2 ... x15) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)