Задать вопрос
9 апреля, 12:30

В двумерном пространстве заданы два вектора. Вычислить векторное произведение векторов. Вводится 4 координаты x1, y1, x2, y2, выводится векторный произведение p1*p2

+3
Ответы (1)
  1. 9 апреля, 14:38
    0
    Программа отдельно вычисляет произведения строк и столбцов заданных ячеек.

    Program n1;

    Uses CRT;

    Const n=10;

    Var a: array[1 ... n, 1 ... n] of integer;

    i, j, x1, x2, y1, y2: integer;

    p1, p2, p3, p4: longint;

    begin

    ClrScr;

    For i:=1 to n do

    begin

    For j:=1 to n do

    begin

    a[i, j]:=random (10) ;

    a[i, j]:=a[i, j]+1;

    write (a[i, j]:3) ;

    end;

    writeln;

    end;

    Writeln ('Vvedite pervyu paru koordinat') ;

    Readln (x1, y1) ;

    Writeln ('Vvedite vtoruu paru koordinat') ;

    Readln (x2, y2) ;

    p1:=1; p2:=1; p3:=1; p4:=1;

    For i:=1 to n do

    begin

    p1:=p1*a[i, y1];

    p2:=p2*a[i, y2];

    end;

    For i:=1 to n do

    begin

    p3:=p3*a[x1, j];

    p4:=p4*a[x2, j];

    end;

    Writeln ('Proizvedenie strok = ', p1*p2) ;

    Writeln ('Proizvedenie stolbcov = ', p3*p4) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В двумерном пространстве заданы два вектора. Вычислить векторное произведение векторов. Вводится 4 координаты x1, y1, x2, y2, выводится ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
Составьте алгоритм, по которому на компьютере будет происходить следующее: в переменную S вводится возраст Саши, в переменную М вводится возраст Маши. В качестве результата на экран выводится фраза "Саша старше Маши" или "Маша старше Саши"
Ответы (1)
Найти значение: min (P1, P2), где P1 - скалярное произведение векторов A и B. P2 - скалярное произведение векторов C и D. Вычисление скалярного произведения векторов оформить подпрограммой. Исходные данные: А = (-5.1, 2.7, 3.4, 6.2) ; В = (1.2, 3.
Ответы (1)