Задать вопрос
24 января, 23:54

Написать программу формирующую двумерный массив размером 4 х4 и выводящую на экран максимальное количество элементов этого массива

+3
Ответы (1)
  1. 25 января, 00:44
    0
    Видимо имеется ввиду выводящий максимальны элемент этого массива

    В данном примере матрица формируется при помощи случайных чисел

    program MatrixMax;

    Uses Crt;

    type matrix=array[1 ... 4,1 ... 4] of real;

    var m:matrix;

    max:real;

    {Порождение матрицы случайным образом}

    procedure Auto;

    var i, j:integer;

    begin

    randomize;

    for i:=1 to 4 do

    begin

    for j:=1 to 4 do

    begin

    m[i, j]:=25+random (21) ;

    end;

    end;

    end;

    {Вывод матрицы на экран}

    procedure PrintMatrix (mas:matrix) ;

    var j, k:integer;

    begin

    for k:=1 to 4 do

    begin

    for j:=1 to 4 do

    begin

    write (mas[k, j]:7:2) ;

    end;

    writeln;

    end;

    end;

    {Нахождение максимального элемента}

    procedure Мax;

    var i, j:integer;

    begin

    max:=m[1,1]

    for i:=1 to 4 do

    begin

    for j:=1 to 4 do

    begin

    if (max
    end;

    end;

    end;

    begin

    Clrscr;

    Auto;

    PrintMatrix;

    Max;

    writeln;

    writeln ('Максимальный элемент матрицы: ', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу формирующую двумерный массив размером 4 х4 и выводящую на экран максимальное количество элементов этого массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25.
Ответы (1)