Задать вопрос
22 июня, 16:29

Информатика "Программирование разветвляющихся алгоритмов"

1. Увеличить число X на 10, если оно положительное, во всех остальных случаях уменьшить на 10.

2. Увеличить число X на 5, если оно положительное.

+2
Ответы (1)
  1. 22 июня, 18:16
    0
    var x:integer;

    Begin

    read (x) ;

    if x>0 then x:=x+10

    else x:=x-10;

    writeln (x) ;

    read (x) ;

    if x>0 then x:=x+5;

    writeln (x) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Информатика "Программирование разветвляющихся алгоритмов" 1. Увеличить число X на 10, если оно положительное, во всех остальных случаях ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую по длинам сторон A. B. C, является ли треугольник равнобедренным. 2. Даны радиусы круга и сторона квадрата. У какой фигуры площадь больше? 3.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Дано число. Если оно делится на 11, то уменьшить ч Дано число. Если оно делится на 11, то уменьшить число в 11 раз, в противном случае уменьшить число на 11. исло в 11 раз, в противном случае уменьшить число на 11.
Ответы (1)
Дано число. Если оно больше 10, то вывести на консоль, если оно меньше 3, увеличить его на 11 и вывести на консоль, в остальных случаях уменьшить на 100. PascalABC
Ответы (1)