Задать вопрос
16 августа, 16:15

Распишите.

1. определите значение целочисленных переменных x и y после выполнения фрагмента программы

х : = 19;

у : = 3;

z : = у*2;

у : = х mod у;

х : = х - z;

у : = у + z;

+4
Ответы (1)
  1. 16 августа, 17:28
    0
    Var

    x, y, z: integer;

    begin

    x : = 19;

    y : = 3;

    z : = y * 2;

    y : = x mod y;

    x : = x - z;

    y : = y + z;

    writeln ('x = ', x, ', y = ', y, ', z = ', z) ;

    end.

    Вывод

    x = 13, y = 7, z = 6
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Распишите. 1. определите значение целочисленных переменных x и y после выполнения фрагмента программы х : = 19; у : = 3; z : = у*2; у : = х ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X) ; 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
3. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=2; for i:=0 to 2 do begin a:=a+i; end; Ответ: введите число 4.
Ответы (2)
Определить значение выражения: 1) 10 div 15 2) 10 div 2 3) 10 mod 2 4) 10 mod 17 5) 123 mod 10 6) 123 div 10 7) 1 div 2 8) 123 mod 1000 9) 100 mod 27 div 3 10) 100 div 5 mod 3 11) 98725 div 1000 mod 10 12) 100 mod 5 div 3
Ответы (1)
1) Определите значение переменных a и b после выполнения фрагмента алгоритма: a: = 86; b: = a mod 10 + 14; a: = а div 3 * 5; 2) Определите значение переменных a и b после выполнения фрагмента алгоритма: a: = 8673; b: = (a mod 100) * 10 + 14;
Ответы (1)