Задать вопрос
21 октября, 15:21

тема: Структурный данный. Массивы. (Паскаль) Месяц 1 2 3 4 5 6 7 8 9 10 11 12 Темпреатура - 31 - 18 - 7.5 5.8 10 18 22.2 24 17 5.4 - 7 - 11 1) вычислите средние температуры зимних месяцев, весенних месяцев, летних месяцев и осенних месяцев. 2) Разработать схему алгоритма и программу, которая вводит массив из N целых чисел и выводит номера отрицательных элементов и сами эти элементы.

+1
Ответы (1)
  1. 21 октября, 15:44
    0
    Program temperature;

    Uses crt;

    Var

    x : array [1 ... 2,1 ... 12] of real;

    t, m, i : integer;

    z, v, l, o : real;

    Begin

    z:=0; v:=0; l:=0; o:=0;

    for i:=1 to 12 do

    x[1, i]:=i;

    x[2,1]:=-11; x[2,2]:=-31; x[2,3]:=-18; x[2,4]:=-7.5; x[2,5]:=5.8; x[2,6]:=10; x[2,7]:=18;

    x[2,8]:=22.2; x[2,9]:=24; x[2,10]:=17; x[2,11]:=5.4; x[2,12]:=-7;

    for i:=1 to 3 do

    z:=z+x[2, i];

    for i:=4 to 6 do

    v:=v+x[2, i];

    for i:=7 to 9 do

    l:=l+x[2, i];

    for i:=10 to 12 do

    o:=o+x[2, i];

    z:=z/3; v:=v/3; l:=l/3; o:=o/3;

    writeln ('Средняя температура зимних месяцев = ', z:3:1) ;

    writeln ('Средняя температура весенних месяцев = ', v:3:1) ;

    writeln ('Средняя температура летних месяцев = ', l:3:1) ;

    writeln ('Средняя температура осенних месяцев = ', o:3:1) ;

    End.

    Program num2;

    Uses crt;

    Var

    x : array[1 ... 100] of integer;

    i, n : integer;

    Begin

    clrscr;

    write ('N=') ; readln (n) ;

    for i:=1 to n do

    begin

    write ('x[', i,']=') ; readln (x[i])

    end;

    for i:=1 to n do

    if x[i]<0 then writeln ('x[', i,']<0 and x[', i,']=', x[i]) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «тема: Структурный данный. Массивы. (Паскаль) Месяц 1 2 3 4 5 6 7 8 9 10 11 12 Темпреатура - 31 - 18 - 7.5 5.8 10 18 22.2 24 17 5.4 - 7 - 11 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
Разработать схему алгоритма, который вводит массив из N целых чисел и выводит номера отрицательных элементов и сами эти элементы. Протестировать алгоритм для следующих массивов: а) 3 5 - 2 3 - 2 0 - 6 - 8 1 б) - 1 - 2 - 3 - 4 0 - 1 2 3
Ответы (2)
Разработать блок-схему и программу, которая запрашивает массив из N целых чисел, выводит номера отрицательных элементов и сами эти элементы) Вот эти числа: а) 3,5,-2,3,-2,0,-6,-8,1; б) - 1,-2,-3,-4,0,-1,2,3)
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
доброго времени суток.) кто-нибудь может помочь? ибо я совсем не вывожу информатику. 1. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами.
Ответы (1)