Задать вопрос
13 мая, 20:25

Разработать схему алгоритма, который вводит массив из N целых чисел и выводит номера отрицательных элементов и сами эти элементы. Протестировать алгоритм для следующих массивов: а) 3 5 - 2 3 - 2 0 - 6 - 8 1 б) - 1 - 2 - 3 - 4 0 - 1 2 3

+5
Ответы (2)
  1. 13 мая, 20:39
    0
    Program Pr1;

    uses crt;

    var mas:array[byte] of integer;

    i, n:integer;

    Begin

    clrscr;

    readln (n) ;

    for i:=1 to n do read (mas[i]) ;

    for i:=1 to n do if mas[i]<0 then writeln (i,' ', mas[i]) ;

    end.
  2. 13 мая, 22:48
    0
    Program Pr1;

    uses crt;

    var mas:array[byte] of integer;

    i, n:integer;

    Begin

    clrscr;

    readln (n) ;

    for i:=1 to n do read (mas[i]) ;

    for i:=1 to n do if mas[i]<0 then writeln (i,' ', mas[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Разработать схему алгоритма, который вводит массив из N целых чисел и выводит номера отрицательных элементов и сами эти элементы. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
1. Разработать программу алгоритма для подсчета количества отрицательных чисел среди целых чисел a, b, c. Протестировать алгоритм для всех возможных случаев (когда количество отрицательных чисел равно 0, 1, 2 и 3). 2.
Ответы (1)
доброго времени суток.) кто-нибудь может помочь? ибо я совсем не вывожу информатику. 1. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами.
Ответы (1)
Разработать блок-схему и программу, которая запрашивает массив из N целых чисел, выводит номера отрицательных элементов и сами эти элементы) Вот эти числа: а) 3,5,-2,3,-2,0,-6,-8,1; б) - 1,-2,-3,-4,0,-1,2,3)
Ответы (1)
Напишите программу, которая вводит массив из N целых чисел и выводит на экран элементы, кратные числу K. Протестировать программу на следующих исходных данных: а) k=3 Массив: 2 6 - 9 4 5 12 - 15 б) k=4 Массив: 9 0 8 124 - 16 11 19
Ответы (1)