Задать вопрос
23 августа, 21:46

вычислить сумму положительных и сумму отрицательных значений функции z=cos (nx+a) sin (nx-a), где n=1,2, ... 10

+3
Ответы (1)
  1. 24 августа, 01:34
    0
    Надеюсь мое решение правильное, просто не знал что делать с переменными a и x

    Program Pr1;

    uses crt;

    var n, z, x, a, s1, s2:real;

    Begin

    clrscr;

    readln (x, a) ;

    z:=1;

    n:=1;

    s1:=0;

    s2:=0;

    while n<=10 do begin

    z:=cos (n*x+a) * sin (n*x-a) ;

    if z>0 then s1:=s1+z

    else s2:=s2+z;

    n:=n+1;

    end;

    writeln (' + ', s1:8:3,' - ', s2:8:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «вычислить сумму положительных и сумму отрицательных значений функции z=cos (nx+a) sin (nx-a), где n=1,2, ... 10 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Записать в виде обычной математической формулы 1) y:=2*sin (x) * sqrt (x+sqrt (abs (x))) 2) y: = sqrt (sin (x) + sin (sqrt (x))) 3) y: = sqrt (abs (x-1) + sqrt (sin (x))) 4) y: = (5*sin (x) + 4) / 2*15*sin (sqrt (x)) 5) k+15*x / (2*sin (x)) 6) y:=
Ответы (1)
Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1 ... 10]
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.
Ответы (1)
Дано массив с N положительных и отрицательных чисел. а) найти среднее аримфметичкое отдельно для положительных, среднее геометрическое - для негативных. б) найти максимальную по длинне последовательность чисел с одинаковым знаком.
Ответы (1)