Задать вопрос
26 марта, 19:09

даны 2 действительных числа. Меньше из них заменить полусуммой этих чисел, а большее-произведением этих чисел.

прошу написать на русском языке

+4
Ответы (1)
  1. 26 марта, 22:50
    0
    извини, но из языков программирования которые пишут на русском знаю только 1 С и это как по мне издевательство

    пишу на старом добром паскале

    var a, b, min, max:real;

    read (a, b) ;

    if (a
    min:=a;

    max:=b;

    a: = (min+max) / 2;

    b:=min*max;

    end

    else begin

    min:=b;

    max:=a;

    b: = (min+max) / 2;

    a:=min*max;

    end;

    writeln (a, b) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «даны 2 действительных числа. Меньше из них заменить полусуммой этих чисел, а большее-произведением этих чисел. прошу написать на русском ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задачи по Паскалю. Условный оператор. 1. Даны два действительных числа меньшее из них замените полусуммой их, а большее их произведением. 2. Найдите решение уравнения ах + в=0, если оно существует, если а=0 3.
Ответы (1)
Язык C#. Написать программу на языке C#разветвляющейся структуры согласно вариантам задания 1 (используя if) и задания 2 (используя switch). 1. Даны два числа. Большее из этих двух чисел заменить их полусуммой, а меньшее удвоенным произведением. 2.2.
Ответы (1)
Даны 2 числа меньшее из них заменить полусуммой, а большее число заменить их удвоенным произведением
Ответы (1)
Написать прогу на C# с помощью функции if Даны два числа. Большее из этих двух чисел заменить их полусуммой, а меньшее удвоенным произведением.
Ответы (1)
Даны два числа. Большее из двух данных чисел заменить удвоенным произведением, а меньшее полусуммой этих чисел.
Ответы (1)