Задать вопрос
6 февраля, 05:14

Как составить на языке Паскаль программу вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N?

Вообще с Паскалем у меня полный завал! Если знаете как, то напишите! Желательно с объяснениями, буду благодарна!

+5
Ответы (2)
  1. 6 февраля, 07:34
    0
    Берем и проходим циклом.

    var

    sum, i, n : integer;

    //i - счетчик, в sum - сумма)

    begin

    read (n) ;

    sum : = 0; / / Надо обязательно обнулить

    for i : = 1 to n do

    sum : = sum + i;

    //Таким образом к сумме будут добавлены 1, при следующей интерации 2, и так далее до N

    writeln (sum) ;

    end.

    Постарался объяснить ...
  2. 6 февраля, 08:39
    0
    var sum, n, i:integer;

    begin

    readln (n) ;

    sum:=0;

    for i:=1 to n do

    sum:=sum+i;

    writeln (sum) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как составить на языке Паскаль программу вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N? Вообще с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программы на Паскале, используя цикл "Пока". 1) Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N. 2) Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^N.
Ответы (1)
Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N. Программу напишите на Бейсике
Ответы (1)
Составь алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного с клавиатуры натурального числа N. Напиши программу на Паскале.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих данного заданного числа N. Напишите программу на Паскале. P. S. Тема урока - программирование циклов
Ответы (1)