Задать вопрос
27 июля, 22:18

Задан линейный массив С из N элементов. Подсчитайте произведение элементов массива, которые больше 20, но меньше 30. (Составьте блок-схему и программу)

+5
Ответы (1)
  1. 27 июля, 23:09
    0
    var c:array[1 ... 100] of integer;

    n, i, proizv:integer;

    begin

    write ('введите кол-во элементов массива') ;

    read (n) ;

    For i:=1 to n do

    c[i]:=random (50) ;

    proizv:=1;

    For i:=1 to n do

    if c[i]>20 then

    if c[i]<30 then

    proizv:=proizv*c[i];

    For i:=1 to n do

    write (c[i],' ') ;

    write ('произведение = ', proizv) ;

    end.

    блок-схему нет возможности скинуть, извини

    написал на языке паскаля
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задан линейный массив С из N элементов. Подсчитайте произведение элементов массива, которые больше 20, но меньше 30. (Составьте блок-схему ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1) Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2) Задан массив из 11 целых чисел. Посчитать количество нечётных элементов массива. 3) задан массив из 9 целых чисел. Вывести на экран чётные элементы
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)