Задать вопрос
15 мая, 13:58

даны 5 чисел, найти сумму и кол-во положительных и произведение и кол-во отрицательных.

+5
Ответы (1)
  1. 15 мая, 15:04
    0
    var

    array a[1 ... 5] of integer;

    i, sum, pr, pol, otr:integer;

    for i:=1 to 5 do

    readln (a[i]) ;

    sum:=0;

    pr:=1;

    pol:=0;

    otr:=0;

    for i:=1 to 5 do begin

    sum:=sum+a[i];

    pr:=pr*a[i];

    if a[i]>0 then

    pol:=pol+1;

    if a[i]<0 then

    otr:=otr+1;

    end;

    writeln (sum, ' ', pol, ' ', pr, ' ', otr) ;

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «даны 5 чисел, найти сумму и кол-во положительных и произведение и кол-во отрицательных. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1 ... 10]
Ответы (1)
Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Дано массив с N положительных и отрицательных чисел. а) найти среднее аримфметичкое отдельно для положительных, среднее геометрическое - для негативных. б) найти максимальную по длинне последовательность чисел с одинаковым знаком.
Ответы (1)