Задать вопрос
3 апреля, 08:06

Составить программу сортировки в Паскаль ABC: Даны три числа, расположить их в порядке убывания.

+5
Ответы (1)
  1. 3 апреля, 08:22
    0
    Program p;

    Var

    a, b, c, i, j, n : Integer;

    Begin

    Writeln ('введите три числа') ;

    Readln (a, b, c) ;

    if a>b then if a>c then Writeln (a, c, b)

    else Writeln (c, a, b)

    else if c>b then Writeln (a, b, c)

    else Writeln (b, c, a) ;

    Readln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу сортировки в Паскаль ABC: Даны три числа, расположить их в порядке убывания. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите вопросы по информатике. 1. Какой вид сортировки используют для сортировки по нескольким параметрам? 2. Назначение сортировки 3. Какие типы данных можно сортировать.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Напишите программу, которая сортирует массив и находит количество различных чисел в нем. Используйте алгоритм быстрой сортировки. Пример: Массив: 5 3 4 2 1 6 3 2 4 После сортировки: 1 2 2 3 3 4 4 5 6 Различных чисел: 5
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
1. Составить алгоритм и программу нахождения суммы следующих чисел: 1, 12, 35, 70, 117, ... 532. 2.-х- 3.
Ответы (1)