Задать вопрос
10 октября, 10:20

Напишите программу, которая сортирует массив и находит количество различных чисел в нем.

Используйте алгоритм быстрой сортировки.

Пример:

Массив:

5 3 4 2 1 6 3 2 4

После сортировки:

1 2 2 3 3 4 4 5 6

Различных чисел: 5

+3
Ответы (1)
  1. 10 октября, 10:40
    0
    Var i, j, h, a, z, n, k: integer;

    array1: array [1 ... 100] of integer;

    array2: array [1 ... 100] of integer;

    procedure swap (var x, y: integer) ;

    var t: integer;

    begin

    t : = x; x : = y; y : = t

    end;

    begin

    randomize;

    write ('Введите значение N: ') ;

    readln (n) ;

    for i : = 1 to n do

    begin

    array1[i] : = random (10) + 1;

    end;

    for i : = 1 to n do

    begin

    writeln ('Массив:') ;

    for i : = 1 to n do write (array1[i], ' ') ;

    writeln;

    end;

    for h : = 1 to n - 1 do

    for z : = 1 to n - h do

    if array1[z] > array1[z + 1] then

    swap (array1[z], array1[z + 1]) ;

    for i : = 1 to n do

    begin

    writeln ('После сортировки:') ;

    for i : = 1 to n do write (array1[i], ' ') ;

    writeln;

    end;

    for i:=1 to n do

    begin

    k : = 0;

    for j : = 1 to n do

    if array1[i] array1[j] then k:=k+1;

    if k = n - 1 then array2[i] : = array1[i];

    end;

    for i : = 1 to n do

    if array2[i] > 0 then a : = a + 1;

    writeln ('Различных чисел: ', a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая сортирует массив и находит количество различных чисел в нем. Используйте алгоритм быстрой сортировки. Пример: ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Помогите вопросы по информатике. 1. Какой вид сортировки используют для сортировки по нескольким параметрам? 2. Назначение сортировки 3. Какие типы данных можно сортировать.
Ответы (1)
Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и: а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)