Задать вопрос
11 августа, 12:35

Составить программу, в которой осуществляется ввод трёх целых чисел с клавиатуры и вывод на экран монитора значения их суммы.

+1
Ответы (2)
  1. 11 августа, 14:36
    0
    Ну вот так это будет выглядеть с ветвлением и возможностью повторять вычисления без повторного запуска программы.

    var a, b, c, d, z:integer;

    begin

    writeln ('Введите 1 число') ;

    read (a) ;

    writeln ('Введите 2 число') ;

    read (b) ;

    writeln ('Введите 3 число') ;

    read (c) ;

    d:=a+b+c;

    writeln ('Сумма чисел ', a,'+', b,'+', c,'=', d) ;

    writeln ('Хотите ли вы решить еще один пример? 1-ДА, 0-Нет') ;

    read (z) ;

    while (z = 1) do

    begin

    writeln ('Введите 1 число') ;

    read (a) ;

    writeln ('Введите 2 число') ;

    read (b) ;

    writeln ('Введите 3 число') ;

    read (c) ;

    d:=a+b+c;

    writeln ('Сумма чисел ', a,'+', b,'+', c,'=', d) ;

    writeln ('Хотите ли вы решить еще один пример? 1-ДА, 0-Нет') ;

    read (z) ;

    end;

    end.
  2. 11 августа, 14:58
    0
    Ну вот так это будет выглядеть с ветвлением и возможностью повторять вычисления без повторного запуска программы.

    var a, b, c, d, z:integer;

    begin

    writeln ('Введите 1 число') ;

    read (a) ;

    writeln ('Введите 2 число') ;

    read (b) ;

    writeln ('Введите 3 число') ;

    read (c) ;

    d:=a+b+c;

    writeln ('Сумма чисел ', a,'+', b,'+', c,'=', d) ;

    writeln ('Хотите ли вы решить еще один пример? 1-ДА, 0-Нет') ;

    read (z) ;

    while (z = 1) do

    begin

    writeln ('Введите 1 число') ;

    read (a) ;

    writeln ('Введите 2 число') ;

    read (b) ;

    writeln ('Введите 3 число') ;

    read (c) ;

    d:=a+b+c;

    writeln ('Сумма чисел ', a,'+', b,'+', c,'=', d) ;

    writeln ('Хотите ли вы решить еще один пример? 1-ДА, 0-Нет') ;

    read (z) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, в которой осуществляется ввод трёх целых чисел с клавиатуры и вывод на экран монитора значения их суммы. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы