Задать вопрос
7 августа, 03:24

с клавиатуры вводится среднесуточная температура за октябрь определите количество дней в которые были заморозки

Программу надо в паскале написать

+2
Ответы (2)
  1. 7 августа, 03:54
    0
    program a1;

    uses crt;

    var a:array[1 ... 31] of longint; k, i:integer;

    begin

    clrscr;

    for i:=1 to 31 do begin

    write ('Введите температуру ', i,' числа:') ;

    readln (a[i]) ;

    if a[i]<0 then k:=k+1;

    end;

    writeln (' Количество дней в которые были заморозки = ', k) ;

    readln

    end.

    P. S. Если паскаль ABC, то выделенное писать не обязательно
  2. 7 августа, 06:48
    0
    var temp:array[1 ... 31] of integer;

    k, i:integer;

    begin

    for i:=1 to 31 do readln (temp[i]) ;

    for i:=1 to 31 do

    if a[i]<0 then inc (k) ;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «с клавиатуры вводится среднесуточная температура за октябрь определите количество дней в которые были заморозки Программу надо в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
1. Вводится номер месяца. Надо определить к какому сезону относится этот месяц 2. Написать программу, которая грамотно печатает фразу "У меня К друзей". К вводится с клавиатуры.
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)