Задать вопрос
4 июля, 08:25

Паскаль. Составить программу введённого пользователем числа (целое или нет; положительное, отрицательное или нуль; чётное или нечётное)

+1
Ответы (1)
  1. 4 июля, 09:06
    0
    var a: real;

    begin

    read (a) ;

    if (a mod 2=0) and (a0) then write ('четное') ;

    if (a mod 2=0) and (a0) then write ('не четное') ;

    if a=0 then write ('нуль') ;

    if a>0 then write ('положительное') ;

    if a<0 then write ('отрицательное') ;

    if a=0 then write ('нуль') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Составить программу введённого пользователем числа (целое или нет; положительное, отрицательное или нуль; чётное или нечётное) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Составить программу в паскале Ввести число. Если оно четное и положительное, разделить его на 4, если четное и отрицательное - умножить на 5, если нечетное - возвести в квадрат.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. Составить программу, отгадывающую натуральное четное число, загаданное пользователем. Ниже представлен рекомендуемый вариант диалога во время работы программы (жирным шрифтом выделены данные, вводимые пользователем).
Ответы (1)
Составить программу, которая запрашивает целое число, не равное нулю, сообщает, положительное оно или отрицательное. и при этом положительное число уменьшает в 2 раза, а отрицательное возводит в квадрат.
Ответы (1)