Задать вопрос
7 февраля, 06:06

Как написать программу которая напишет все целые числа от 1 до 50 которые кратны 9 и посчитает их произведение и сумму

+2
Ответы (1)
  1. 7 февраля, 08:47
    0
    Берем цикл от 1 до 50, идем и проверяем все числа на кратность 9, если кратны, то пишем число и добавляем к сумме (и умножаем произведение).

    var

    sum, mul, i : integer;

    begin

    sum : = 0; mul : = 1;

    for i : = 1 to 50 do

    if i mod 9 = 0 then

    begin

    write (i, ' ') ;

    sum : = sum + i;

    mul : = mul * i;

    end;

    writeln;

    writeln ('sum = ', sum) ;

    writeln ('mul = ', mul) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как написать программу которая напишет все целые числа от 1 до 50 которые кратны 9 и посчитает их произведение и сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Помогите написать программу на Паскале. Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, сумму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Задание 1. составьте программу вычисления количества двузначных чисел, которые кратны 2 и 3. задание 2. составьте программу, выводящую на экран все двузначные числа, у которых первая цифра в два раза больше второй. задание 3.
Ответы (1)