Задать вопрос
3 октября, 17:18

Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^n. Напишите программу на Паскале.

+3
Ответы (1)
  1. 3 октября, 17:34
    0
    var s, x, n, i:integer;

    Begin

    read (x, n) ;

    s:=1;

    for i: = 1 to n do

    s:=s*x;

    writeln (s) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^n. Напишите программу на Паскале. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программы на Паскале, используя цикл "Пока". 1) Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N. 2) Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^N.
Ответы (1)
Дано целое число X и натуральное N. Составьте алгоритм вычисления X^N. Проверьте алгоритм трассировкой. Напишите программу на Паскале.
Ответы (1)
Дано целое число X и натуральное число N. Составте алгоритм вычисления X^N. Напишите программу на Паскале.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
дано целое число X и натуральное N. составить алгоритм вычисления Х в степени N. Написать программу на паскале.
Ответы (1)