Задать вопрос
3 октября, 18:18

Напишите программу. Определить номер подъезда и этаж квартиры по её номеру, если известна этажность дома и количество квартир на лестничной площадке

+4
Ответы (1)
  1. 3 октября, 19:36
    0
    Program P1;

    var z, x, y, p, e:integer;

    begin

    write ('Количество этажей = ') ; readln (x) ;

    write ('Количество квартир на лестничной площадке = ') ;

    readln (y) ;

    write ('Номер квартиры = ') ; readln (z) ;

    p: = (z-1) div (x*y) + 1;

    e: = ((z - (p-1) * x*y) - 1) div y + 1;

    writeln ('Квартира ', z,' находится в ', p,' подъезде на ', e,' этаже') ;

    end.

    Пример:

    Количество этажей = 9

    Количество квартир на лестничной площадке = 4

    Номер квартиры = 67

    Квартира 67 находится в 2 подъезде на 8 этаже
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу. Определить номер подъезда и этаж квартиры по её номеру, если известна этажность дома и количество квартир на лестничной ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
По номеру квартиры определить номер подъезда и этаж. квартира находиться в 5 этадном доме по 4 квартиры на каждом этаже.
Ответы (1)
Боря Лейкин на время каникул устроился работать помощником почтальона. Сегодня ему необходимо доставить телеграмму в квартиру n девятиэтажного дома, в котором несколько подъездов, а на каждом этаже подъезда по 4 квартиры.
Ответы (1)
Живет в доме в котором 8 квартир вы знаете В каком именно квартиры он живет дома встретил девочку которая знает номер квартиры на после каждого вопроса головой да или нет Какое наименьшее количество вопросов необходимо задать девушке чтобы узнать
Ответы (1)
Определите номер подъезда и этажа девятиэтажного дома, если на каждом этаже по 4 квартиры и известен номер квартиры.
Ответы (1)
Курьеру сообщили что он должен доставить заказ на 8 этаж какова этажность этого здания, если известно, что информационная емкость этого сообщения 4 бита
Ответы (1)