Задать вопрос
17 марта, 08:59

даны 10 произвольных действительных числа (вводятся с клавиатуры). Подсчитать количество отрицательных чисел помогите составить программу

+5
Ответы (2)
  1. 17 марта, 09:26
    0
    Program Zorkini;

    uses crt;

    const n=10;

    var

    Z: real;

    i, k: integer;

    begin

    k:=0;

    for i:=1 to n do

    begin

    write ('Введите ', i,'-e число ') ;

    readln (z) ;

    if z<0 then k:=k+1;

    end;

    writeln ('Количество отрицательных чисел ', k) ;

    end.
  2. 17 марта, 10:12
    0
    var a, s, i:integer;

    begin

    s:=0;

    for i:=1 to 10 do

    begin

    write ('Число: ') ; readln (a) ;

    if a<0 then s:=s+1;

    end;

    writeln ('Кол-во отрицательных чисел: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «даны 10 произвольных действительных числа (вводятся с клавиатуры). Подсчитать количество отрицательных чисел помогите составить программу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
С клавиатуры вводятся N чисел. Составьте программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введенных чисел. Значение N и сами числа вводится с клавиатуры.
Ответы (2)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1. с клавиатуры вводится n действительных чисел. Определить сколько в данной последовательности нечетных отрицательных чисел. 2. Составить программу на языке Паскаль вычисления кубов чисел вводимых с клавиатуры. 3.
Ответы (1)