Задать вопрос
23 декабря, 11:14

1. Дан целочисленный массив из 30 элементов, которые могут принимать значения от 150 до 200 - рост учащихся выпускного класса. В баскетбольную команду берут тех, чей рост не менее 180 см. Напишите программу, которая подсчитывает число претендентов в состав баскетбольной команды и выводит номера подходящих кандидатур.

+4
Ответы (1)
  1. 23 декабря, 14:35
    0
    const

    n = 30;

    var

    a:array[1 ... n] of byte;

    i, count:integer;

    begin

    randomize;

    for i : = 1 to n do

    begin

    a[i] : = random (51) + 150;

    writeln ('Рост претендета № ', i:2, ' - ', a[i]) ;

    end;

    write ('Номера подходящих кандидатур: ') ;

    for i : = 1 to n do

    if a[i] > = 180 then

    begin

    inc (count) ;

    write (i, ' ') ;

    end;

    writeln;

    writeln ('Общее количество подходящих претендентов: ', count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дан целочисленный массив из 30 элементов, которые могут принимать значения от 150 до 200 - рост учащихся выпускного класса. В ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от 160 до 200 - рост учащихся выпускного класса. В баскетбольную команду берут тех, чей рост не менее 180 см.
Ответы (1)
Объявлен набор в школьную баскетбольную команду. Известен рост каждого из N учеников, желающих попасть в эту команду. Подсчитайте количество претендентов, имеющих шанс попасть в команду, если рост игрока команды должен быть не менее 170 см.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Объявлен набор в школьную баскетбольную команду. известен рост каждого из n учеников желающих попасть в эту команду.
Ответы (1)