Задать вопрос
8 апреля, 06:57

Написать программу для определения количества и суммы только положительных чисел из 3, введенных с клавиатуры

+5
Ответы (1)
  1. 8 апреля, 08:58
    0
    Var a:array[1 ... 3] of integer;

    i, sum, col:integer;

    begin

    sum:=0;

    col:=0;

    for i:=1 to 3 do readln (a[i]) ;

    for i:=1 to 3 do

    if a[i]>0 then

    begin

    col:=col+1;

    sum:=sum+a[i];

    end;

    writeln ('Сумма: ', sum) ;

    writeln ('Кол-во: ', col) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для определения количества и суммы только положительных чисел из 3, введенных с клавиатуры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Написать программу для определения количества и суммы только положительных чисел из 3, введенных с клавиатуры, на pascal
Ответы (1)
Составьте программу, которая: а) Определяет коды двух введённых с клавиатуры символов; б) Выполняет операцию сцепления трёх введённых с клавиатуры символов; на Pascal
Ответы (1)
Помогите написать программы ... Задача 1 Напишите программу, умеющую проверить положительное ли число, введённое с клавиатуры Задача 2 Напишите программу в которой из двух введенных с клавиатуры чисел, большее из них выведется на экран Задача 3
Ответы (1)
Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.
Ответы (1)