Задать вопрос
2 июня, 21:43

Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.

+4
Ответы (1)
  1. 2 июня, 22:41
    0
    Var x, otrc, poloz: integer;

    begin

    repeat

    write ('Введите число: ') ;

    readln (x) ;

    if x > 0 then inc (poloz) ;

    if x < 0 then inc (otrc) ;

    until x = 0;

    writeln ('Количество положительных чисел: ', poloz) ;

    writeln ('Количество отрицательных чисел: ', otrc) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
С клавиатуры вводятся N чисел. Составьте программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введенных чисел. Значение N и сами числа вводится с клавиатуры.
Ответы (2)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Дан массив из N элементов (12 элементов), заданный случайным образом от - 10 до 10. Вывести на экран этот массив. С клавиатуры вводятся два числа меньше N. Вывести на экран часть массива входящих в диапазон, двух введенных чисел.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)