Задать вопрос
12 ноября, 05:51

1. Напишите программу, которая в последовательности натуральных чисел определяет количество всех нечётных чисел, кратных 7. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество всех чётных чисел, кратных 7.

+5
Ответы (1)
  1. 12 ноября, 08:11
    0
    uses crt; var i, n, k:integer; a:array[1 ... 100] of integer; begin writeln ('введите числа последовательности. Окончанием ввода будет число 0') ; i:=0; n:=0; repeat i:=i+1; n:=n+1; read (a[i]) ; write (' ') ; until (a[i]=0) or (i>1000) ; writeln; k:=0; writeln ('Последовательность:') ; for i:=1 to n-1 do begin write ('a[', i,']=', a[i],' ') ; if ((a[i] mod 2) = 0) and ((a[i] mod 7) = 0) then k:=k+1; end; writeln ('кол-во целых чётных чисел кратных 7 - ', k) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Напишите программу, которая в последовательности натуральных чисел определяет количество всех нечётных чисел, кратных 7. Программа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (признак окончания ввода,
Ответы (1)