Задать вопрос
10 ноября, 11:48

Дан массив целых чисел из 10 элементов поменять местами первый максимальный и последний отрицательный элементы массива. Составить программу в паскале

+3
Ответы (1)
  1. 10 ноября, 14:50
    0
    Var

    A:array[1 ... 10] of integer;

    i, m, o:integer;

    Begin

    WriteLn ('Введите массив') ;

    For i: = 1 to 10 do

    Begin

    Read (A[i]) ;

    End;

    m:=10;

    For i: = 9 downto 1 do

    if A[i]>=A[m] then m:=i;

    For i: = 10 downto 1 do

    if A[i]<0 then

    Begin

    o:=i;

    Break

    End;

    if o = 0 then WriteLn ('Отрицательных чисел нет!')

    else

    Begin

    i:=A[o];

    A[o]:=A[m];

    A[m]:=i;

    For i: = 1 to 10 do

    Write (A[i],' ')

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив целых чисел из 10 элементов поменять местами первый максимальный и последний отрицательный элементы массива. Составить программу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)