Задать вопрос
19 июня, 01:23

Дан массив чисел (n меньше либо равно 10), все числа вводятся вручную, посчитайте, сколько в нём пар элементов равных друг другу, считается, что любые два элемента равные друг другу образуют пару, которую нужно посчитать (Паскаль)

+2
Ответы (1)
  1. 19 июня, 04:44
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    k, i, j:integer;

    begin

    for i:=1 to n do read (a[i]) ;

    k:=0;

    for i:=1 to n-1 do

    for j:=i+1 to n do

    if a[i]=a[j] then k:=k+1;

    writeln ('k = ', k) ;

    end.

    Пример:

    12 56 38 12 85 12 60 45 38 15

    k = 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив чисел (n меньше либо равно 10), все числа вводятся вручную, посчитайте, сколько в нём пар элементов равных друг другу, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)