Задать вопрос
11 декабря, 02:58

Легенда о происхождении шахмат: мудрец попросил у раджи плату: за первую клетку доски - 1 рисовое зерно, за каждую следующую - вдвое больше, чем за предыдущую.

Написать программу, подсчитывающую количество зёрен, которое раджа должен был заплатить всего за первые 20 клеток шахматной доски.

+4
Ответы (1)
  1. 11 декабря, 06:02
    0
    Program radga; var count: integer; i: integer; begin count : = 1; for i: = 1 to 20 do begin count: = count * 2; end; writeln (count) ; end.

    вроде так, не понял одно: нужно было умножать или добавлять так что попробовал умножить)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Легенда о происхождении шахмат: мудрец попросил у раджи плату: за первую клетку доски - 1 рисовое зерно, за каждую следующую - вдвое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На шахматной доске 64 клетки. На первую клетку кладут 1 зерно, на вторую-2 зерна, на третью - 3 зерна и т. д.: на каждую следующую клетку кладут на одно зерно больше, чем на предыдущую.
Ответы (1)
Задача. По древней легенде мудрец, придумавший шахматы потребовал у персидского шаха такое вознаграждение: Пусть на шахматную доску кладут зёрна: на 1-ую 1 зерно, на 2-ую - 2 зерна, на 3-ую - 4 зерна, на 4-ую - 8 зёрен. (т. е.
Ответы (1)
Составить функцию, которая определяет, сколько зерен попросил положить на N-ую клетку изобретатель шахмат (на 1-ую - 1 зерно, на 2-ую - 2 зерна, на 3-ю - 4 зерна, ...) Пример: Введите номер клетки: 28 На 28-ой клетке 134217728 зерен.
Ответы (1)
1) написать программу На столе стоит 10 кастрюль, которые необходимо заполнить водой. В первую кастрюлю помещается 0,5 литра воды, а в каждую следующую на 0,5 литра больше, чем в предыдущую. Сколько воды потребуется для заполнения всех кастрюль?
Ответы (1)
Помогите решить в паскаль. По древней легенде мудрец, который изобрел шахматы, потребовал от персидского шаха такое количество пшеницы, чтобы им можно было покрыть шахматную доску, положив на первую клетку 1 зерно, на вторую - 2, на третью - 4 и т.
Ответы (1)