Задать вопрос
1 марта, 09:05

Дан массив целых чисел из 10 элементов вставить число к перед элементами массива кратными заданному числу r (k и r вводится с клавиатуры) составить программу

+4
Ответы (2)
  1. 1 марта, 09:34
    0
    Var

    A:array[1 ... 10] of integer;

    B:array[1 ... 20] of integer;

    i, k, r, N:integer;

    Begin

    N:=0;

    Write ('k = ') ; Read (k) ;

    Write ('r = ') ; Read (r) ;

    if r = 0 then WriteLn ('На ноль делить нельзя!')

    else

    Begin

    WriteLn ('Введите массив') ;

    For i: = 1 to 10 do

    Begin

    Read (A[i]) ;

    if A[i] mod r = 0 then

    Begin

    N:=N+1;

    B[N]:=k

    End;

    N:=N+1;

    B[N]:=A[i]

    End;

    For i: = 1 to N do

    Write (B[i],' ')

    End

    End.
  2. 1 марта, 12:45
    0
    Const n=10;

    Var

    a:array[1 ... 2*n] of integer;

    i, j, l, k, r:integer;

    Begin

    Randomize;

    for i:=1 to n do begin

    a[i]:=random (21) ;

    write (a[i]:3) ;

    end;

    writeln;

    Write ('k = ') ; Readln (k) ;

    Write ('r = ') ; Readln (r) ;

    For i:=n downto 1 do

    if a[i] mod r = 0 then

    begin

    l:=l+1;

    for j:=n+l-1 downto i do a[j+1]:=a[j];

    a[i]:=k;

    end;

    for i:=1 to n+l do write (a[i]:3) ;

    writeln;

    End.

    Пример:

    2 12 3 20 1 9 11 8 15 14

    k = 5

    r = 2

    5 2 5 12 3 5 20 1 9 11 5 8 15 5 14
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив целых чисел из 10 элементов вставить число к перед элементами массива кратными заданному числу r (k и r вводится с клавиатуры) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)