Задать вопрос
30 июня, 09:48

1. С клавиатуры вводится X и N. Составь алгоритм вычисления X в степени N. Напиши программу на Паскале

+3
Ответы (2)
  1. 30 июня, 12:07
    0
    Var

    x, n, res : integer;

    begin

    res : = 1;

    readln (x) ;

    readln (n) ;

    for var i:=1 to n do res : = res * x;

    writeln (res) ;

    end.

    пишу с телефонв, не уверен, может быть в строке for ... надо n-1 а не просто n
  2. 30 июня, 13:44
    0
    var

    n, i, a: integer;

    p: BigInteger;

    begin

    p : = 1;

    Writeln ('Введите числа') ;

    Write ('a=') ;

    Readln (a) ;

    Write ('n=') ;

    Readln (n) ;

    for i : = 1 To n Do p : = p * a;

    writeln (p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. С клавиатуры вводится X и N. Составь алгоритм вычисления X в степени N. Напиши программу на Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Паскаль 5.3 Напечатать "столбиком": а) все целые числа от 20 до 35 б) квадраты всех целых чисел от a до 50 (значение a вводится с клавиатуры; b>=10) в) третьи степени всех целых чисел от a до 50 (значение a вводится с клавиатуры; a
Ответы (1)
1. с клавиатуры вводится n действительных чисел. Определить сколько в данной последовательности нечетных отрицательных чисел. 2. Составить программу на языке Паскаль вычисления кубов чисел вводимых с клавиатуры. 3.
Ответы (1)