Задать вопрос
9 сентября, 20:42

Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. Используйте процедуру.

Входные данные

Входная строка содержит неотрицательное число N.

Выходные данные

Программа должна вывести в столбик все цифры введённого числа, начиная с первой.

Примеры

входные данные

1234

выходные данные

1

2

3

4

На паскале.

+4
Ответы (1)
  1. 9 сентября, 21:30
    0
    Без рекурсии:

    Procedure ABC (N:integer) ;

    Var

    C:integer;

    Begin

    C:=0;

    While N>0 do

    Begin

    C:=C*10+N mod 10;

    N:=N div 10

    End;

    While C>0 do

    Begin

    WriteLn (C mod 10) ;

    C:=C div 10

    End

    End;

    Var

    N:integer;

    Begin

    Write ('N = ') ; ReadLn (N) ;

    ABC (N) ;

    End.

    С рекурсией:

    Procedure ABC (N:integer) ;

    Begin

    if N>0 then

    Begin

    ABC (N div 10) ;

    WriteLn (N mod 10) ;

    End

    End;

    Var N:integer;

    Begin

    Write ('N = ') ; ReadLn (N) ;

    ABC (N) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. Используйте процедуру. Входные данные Входная ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
В PascalABC Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), у которых первая и последняя цифры десятичной записи одинаковые.
Ответы (1)
Напишите программу, которая выводит все простые числа в диапазоне от 2 до N (N заранее неизвестно). Входные данные Входная строка содержит целое число N.
Ответы (1)