Задать вопрос
16 июня, 21:24

В двумерном массиве (случайно заполненном) найти минимальный и максимальный элемент

+2
Ответы (1)
  1. 16 июня, 22:23
    0
    Const

    K = 3;

    N = 4;

    Var

    A:array[1 ... K, 1 ... N] of integer;

    Max, Min, i, j:integer;

    Begin

    For i: = 1 to K do

    Begin

    For j: = 1 to N do

    Begin

    A[i, j]:=random (21) - 10;

    Write (A[i, j]:3,' ')

    End;

    WriteLn

    End;

    Max:=A[K, N];

    Min:=A[K, N];

    For i: = 1 to K do

    For j: = 1 to N do

    Begin

    if Max
    if Min>A[i, j] then Min:=A[i, j]

    End;

    WriteLn ('Min = ', Min) ;

    WriteLn ('Max = ', Max) ;

    End.

    Пример:

    -3 - 2 5 - 8

    2 - 3 7 5

    -10 - 2 7 4

    Min = - 10

    Max = 7
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В двумерном массиве (случайно заполненном) найти минимальный и максимальный элемент ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задачка в паскале. В двумерном массиве G (7,5) поменять минимальный элемент 2 строки и максимальный элемент 5 столбца. В полученной матрице вычислить значение произведения элементов главной диагонали.
Ответы (1)
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
Паскаль! Заполните массив случайными числами и найти минимальный и максимальный элементы массива и их номера. Пример: Массив: 1 2 3 4 5 Минимальный элемент: A[1]=1 Максимальный элемент: A[5]=5
Ответы (1)
Заполнить массив случайными числами и найти минимальный и максимальный элементы массива и их номера Пример: Массив: 1 2 3 4 5 Максимальный элемент: А[1]=1 Минимальный элемент: А[5]=5 10 класс
Ответы (1)