Задать вопрос
15 июня, 20:57

Напишите программу которая в последовательности натуральных чисел определяет количество всех чисел, кратных 6 и оканчивающихся на 0.

Программа получает на вход натуральные числа, кол-во введенных чисел неизвестно, последовательность чисел оканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). Кол-во чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: кол-во всех чисел последовательности, кратных 6 и оканчивающихся на 0.

+4
Ответы (1)
  1. 15 июня, 23:57
    0
    Program n1;

    var a, k: integer;

    begin

    readln (a) ;

    k:=0;

    while a0 do

    begin

    if (a mod 6=0) and (a mod 10=0) then

    k:=k+1;

    readln (a) ;

    end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу которая в последовательности натуральных чисел определяет количество всех чисел, кратных 6 и оканчивающихся на 0. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4.
Ответы (1)