Задать вопрос
21 марта, 08:51

Напишите программу

Определить кол-во и сумму четных чисел. Последовательность чисел оканчивантся 0. Программа должна вывести 2 числа, первое: длину, последовательность, второе число: сумму четных чисел

Числа при вводе 4,60,15,0

+4
Ответы (1)
  1. 21 марта, 09:57
    0
    Program n1;

    var a, k, sum: integer;

    begin

    readln (a) ;

    k:=0;

    sum:=0;

    while a0 do

    begin

    if (a mod 2=0) then sum:=sum+a;

    k:=k+1;

    readln (a) ;

    end;

    writeln (k) ;

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу Определить кол-во и сумму четных чисел. Последовательность чисел оканчивантся 0. Программа должна вывести 2 числа, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
10. Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)
Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)