Задать вопрос
23 марта, 16:18

Дан массив из 8 элементов. Определить а) сумму всех элементов массива; б) произведение всех элементов массива; в) среднее арифметическое всех элементов массива

+1
Ответы (1)
  1. 23 марта, 20:13
    0
    Var a: array [1 ... 8] of integer;

    s, p, i:integer;

    sr:real;

    begin

    s:=0; p:=1;

    write ('заполни массив') ;

    for i:=1 to 8 do begin

    readln (a[i]) ;

    s:=s+a[i];

    p:=p*a[i];

    end;

    sr:=s/8;

    writeln ('s=', s) ;

    writeln ('p=', p) ;

    writeln ('sr=', sr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 8 элементов. Определить а) сумму всех элементов массива; б) произведение всех элементов массива; в) среднее арифметическое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)