Задать вопрос
22 января, 06:35

Составить алгоритм для вычисления суммы чисел от 1 до n

+3
Ответы (1)
  1. 22 января, 07:17
    0
    Program n1;

    var S, i, n: integer;

    begin

    i:=1;

    S:=0;

    writeln ('введите n: ') ;

    readln (n) ;

    while (i<=n) do

    begin

    S:=S+i;

    i:=i+1;

    end;

    writeln ('сумма: ', S) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить алгоритм для вычисления суммы чисел от 1 до n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какой алгоритм называется линейным? А. Алгоритм, в котором имеется ввод данных, вычисления и вывод результатов. Б. Алгоритм, в котором для получения результатов последовательно выполняются все операторы по одному разу В.
Ответы (1)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)
Напишите программы на Паскале, используя цикл "Пока". 1) Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N. 2) Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^N.
Ответы (1)
Даны числа a b c составьте алгоритм. Составьте алгоритм вычисления половины суммы чисел a и b модуль разности чисел a и c квадрат произведения чисел b и c
Ответы (1)
исключи из предложенных сочетаний слов те, которые невозможны в информатике: 1) линейный алгоритм 2) прямой алгоритм 3) циклический алгоритм 4) разветвляющийся алгоритм
Ответы (2)