Задать вопрос
9 июня, 18:48

Составьте программу определения количества четных и нечетных цифр в записи данного натурально числа

+2
Ответы (2)
  1. 9 июня, 20:24
    0
    Var n, k1, k2:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    k1:=0; k2:=0;

    while n>0 do

    begin

    if n mod 2=0 then k1:=k1+1 else k2:=k2+1;

    n:=n div 10;

    end;

    writeln ('Четных цифр - ', k1,', нечетных - ', k2) ;

    end.

    Пример:

    n = 14568

    Четных цифр - 3, нечетных - 2
  2. 9 июня, 22:08
    0
    Program n1;

    var a, kn, kh: longint;

    begin

    kn:=0;

    kh:=0;

    readln (a) ;

    while a>0 do

    begin

    if (a mod 10) mod 2=0 then kh:=kh+1

    else kn:=kn+1;

    a: = a div 10;

    end;

    writeln ('кол-во четных: ', kh) ;

    writeln ('нечетных: ', kn) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу определения количества четных и нечетных цифр в записи данного натурально числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных.
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма четных цифр и сумма нечетных цифр заданного числа. 2.
Ответы (1)
2. Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма четных цифр и сумма нечетных цифр заданного числа. 2.
Ответы (1)