Задать вопрос
17 февраля, 20:31

Население города увеличивается на от 1.5% до 3.5% каждый год. Каждый же год, по ряду причин фиксируется убыль населения от 0.5% до 3%, 2016 году население составляло 347000.

Напишите программу, которая выведет на экран предсказываемую численость населения города в каждом году вплоть до 2025.

Определить в каком году был наибольшие прирост и убыль населения!

+3
Ответы (1)
  1. 17 февраля, 21:10
    0
    Var n, p, m, max1, max2, im1, im2, i:integer;

    begin

    Randomize;

    n:=347000;

    max1:=0; max2:=0;

    for i:=2017 to 2025 do

    begin

    p:=round (n * (2*random+1.5) / 100) ;

    m:=round (n * (2.5*random+0.5) / 100) ;

    if p>max1 then begin max1:=p; im1:=i; end;

    if m>max2 then begin max2:=p; im2:=i; end;

    n:=n+p-m;

    writeln (i,': n = ', n) ;

    end;

    writeln ('Наибольший прирост = ', max1,', ', im1,' год') ;

    writeln ('Наибольшая убыль = ', max2,', ', im2,' год') ;

    end.

    Пример:

    2017: n = 345558

    2018: n = 349922

    2019: n = 353532

    2020: n = 356979

    2021: n = 364842

    2022: n = 371614

    2023: n = 381020

    2024: n = 389903

    2025: n = 388485

    Наибольший прирост = 11702, 2023 год

    Наибольшая убыль = 10701, 2020 год
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Население города увеличивается на от 1.5% до 3.5% каждый год. Каждый же год, по ряду причин фиксируется убыль населения от 0.5% до 3%, 2016 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Создать на Паскале форму. 1. Население некоторой страны в 1904 году составляло а человек. По переписи населения, проведенной в прошлом году, зарегистрировано b человек. Составить программу вычисления среднегодового прироста населения за этот период.
Ответы (1)
Программа прочитает от пользователя 10 чисел, после этого выведет на экран второе самое большое число. Пример: После ввода: 5 44 80 1 8 100 11 90 2 6 Программа выведет: 90
Ответы (1)
Паскаль. Население некоторой страны в 1904 году было N1 человек, а в 1963 году, стало N2 человек. Написать программу, которая вычисляет среднегодовой прирост населения за этот период при условии, что он был постоянным.
Ответы (2)