Задать вопрос
26 октября, 10:39

Оставить программу ввода величины времени суток t (0<=t<=24) и выдачи текста: "Вы уже проснулись?" - если t=18 "Как работается?" - в остальных случаях.

+3
Ответы (2)
  1. 26 октября, 11:39
    0
    Var

    t:integer;

    begin

    Write ('t=') ; Read (t) ;

    case t of

    0 ... 9:Writeln ('Вы уже проснулись?') ;

    12:Writeln ('Не пора ли обедать?') ;

    18 ... 24:Writeln ('Еще не вечер!') ;

    else Writeln ('Как работается?')

    end

    end.
  2. 26 октября, 14:36
    0
    Var

    t: integer;

    begin

    readln (t) ;

    if t < 10 then print ('Вы уже проснулись?')

    else if t = 12 then print ('Не пора ли обедать?')

    else if t > = 18 then print ('Еще не вечер!')

    else print ('Как работается?')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Оставить программу ввода величины времени суток t (0 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
Собери из суждений правильное умозаключение. №1 все устройства ввода служат для ввода информации. №2 клавиатура служит для ввода информации. №3 клавиатура устройство ввода
Ответы (1)
написать программу для ввода значения величины X целого типа, присваивания величине Y действительного типа значения 2.5, вычисления значения величины Z=X/Y и вывода значения величины Z. Протестировать алгоритм для X=5, X=0, X=-8.75
Ответы (1)
1) составьте программу ввода элементов массива а[1 ... 8 ] с клавиатуры и вывода на экран элементов с отрицательными значениями; 2) составьте программу ввода элементов массива b[1 ...
Ответы (1)