Задать вопрос
19 сентября, 10:49

Проходим цикл с предусловием. Нужно составить в Pascal 2 программы.

1) Дано натуральное число n. Написать программу для вычисления суммы членов последовательности 10,15,20 ... n

2) Вывести степени двойки от 1 до n.

+5
Ответы (1)
  1. 19 сентября, 11:05
    0
    1)

    var a, n, sum:integer;

    begin

    read (n) ;

    a:=10;

    sum:=0;

    while (a n)

    begin

    sum : = sum + a;

    a : = a+5;

    end;

    end.

    2)

    var n:integer;

    begin

    read (n) ;

    for var i : = 1 to n do writeln (power (2, i)) ;

    end.

    ПаскальАБС. Нет - версия Паскаля, нужен фраемфорк. нет в Паскале, если не работает - обнови паскаль
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Проходим цикл с предусловием. Нужно составить в Pascal 2 программы. 1) Дано натуральное число n. Написать программу для вычисления суммы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программы в Паскале: 1) цикл с предусловием. Написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием.
Ответы (1)
Составить программу вычисления суммы всех целых чисел от 0 до 100. 1 использовать цикл с предусловием. 2 использовать цикл с постусловием. 3 использовать цикл с параметром
Ответы (1)
1. Какой тип данных может иметь параметр цикла? 2. В каких случаях при написании программ лучше использовать оператор цикла с предусловием? 3. В каких случаях цикл с предусловием может быть бесконечным? 4.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Дано действительное число A. Требуется найти первое значение числа N, при котором сумма S=1+1/2+1/3+ ...+1/N превышает A. Программу составьте двумя способами: используя цикл с предусловием и цикл с постусловием. В ABC Pascal
Ответы (1)