Задать вопрос
3 марта, 03:57

Напишите программу, заполняющую массив из 45 элементов случайными числами от 0 до 34, выводящую полученный массив на экран, прозврдящую поиск элементов, делящихся на 3, подсчитывающую их количество (с выводом на экран) и считающая среднее арифметическое таких элементов

+4
Ответы (1)
  1. 3 марта, 05:54
    0
    Program n1;

    const n=10;

    var a: array [1 ... n] of integer;

    i, sum, k: integer;

    begin

    randomize;

    for i:=1 to n do

    begin

    a[i]:=random (34) ;

    write (a[i],' ') ;

    end;

    writeln;

    sum:=0;

    k:=0;

    for i:=1 to n do if a[i] mod 3 = 0 then

    begin

    k:=k+1;

    sum:=sum + a[i];

    end;

    writeln ('кол-во: ', k) ;

    writeln ('сумма: ', sum) ;

    writeln ('ср. арифм: ', sum/k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, заполняющую массив из 45 элементов случайными числами от 0 до 34, выводящую полученный массив на экран, прозврдящую ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу, заполняющую массив десятью случайными числами и выводящую на экран: 1) максимальное значение; 2) минимальное значение; 3) среднее арифметическое значение.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1 задача: Массив Z (20) заполнить целыми случайными числами в диапазоне от - 20 до 20. Вычислить CP - среднее арифметическое положительных элементов и CN - среднее арифметическое отрицательных элементов массива Z.
Ответы (1)